RadioLocman.com Electronics ru
Advanced Search +
  
Go Back   RadioLocman Forum > Electronics and ... > Microcontrollers (MCU)

Microcontrollers (MCU) Application and programming of MCUs, Evaluation Kits and Demonstration Boards, Programmers.

Reply
 
Thread Tools Search this Thread
Old 06-24-2017, 05:37 PM   #1
mark
Member
 
Join Date: Oct 2013
Location: Kazakhstan
Posts: 31
mark is on a distinguished road
Default Debug PIC18F26K20 with Pickit3

Our software works on some of our PCBs but not others.
We program them with pickit3 and use ICSP.
Can we just plug the Pickit3 into the board and debug it like that?

When i try to debug I am getting "Connection failed" error in MPLAB X IDE. Do you know why?
I have the 5 pin header in the pickit3 and its connected to the PCB.

I actually programmed the board with this connector/wire assembly so i know the 5 lines are connected (MCLR,Vdd,Vss, PgD,PgC).
mark is offline   Reply With Quote
Old 07-03-2017, 02:43 PM   #2
symbol
Senior Member
 
Join Date: Oct 2013
Posts: 128
symbol is on a distinguished road
Default

need to see the schematic for the relevant part.
IF the debug lines are connected to other components other than the programmer you may have debugging issues

is the board powered by either the PK3 or externally (better)?
symbol is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Controller is not running properly as per logic after removing PICKIT3 programmer Anatoly Microcontrollers (MCU) 1 07-27-2015 12:29 PM

All times are GMT. The time now is 12:54 AM.




Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Slices ↓
Radiolocman facebook Radiolocman twitter Radiolocman google plus